Magicode logo
Magicode
0
1 min read

V言語のvwebでopenssl/rand.hエラー

カサレリア。katzenです。

最近始めたV言語で超簡単なAPIサーバを作る。シリーズで、遭遇したエラーです。

今私はChromebook(CZ1)のLinuxで開発をしているのですが、vwebを使用してビルドしようとしたら、

builder error: Header file <openssl/rand.h>, needed for module `net.openssl` was not found. Please install OpenSSL development headers.

こんな感じのエラーが出てしまいました。

では、早速解決方法です。

sudo apt install libssl-dev

これで大丈夫です。エラーコメントどおりですね。

ちなみにエラーはGoogleで検索すると、大抵誰かが解決してくれています。

同じ様に今回の件を検索すると、 こちらの記事がHit.

・・・ありがとう自分。記事に残しておくの大事。

という経緯があって、

改めてMagicodeの記事にしようと思いこれを書きました。

Discussion

コメントにはログインが必要です。