Magicode logo
Magicode
0
2 min read

【解決】VSCodeでJupyter Notebook使おうとしたらKernelを起動できない

エラー内容

Failed to start the Kernel. 
c:\miniconda3\envs\test\lib\site-packages\traitlets\traitlets.py:2395: FutureWarning: Supporting extra quotes around strings is deprecated in traitlets 5.0. You can use 'hmac-sha256' instead of '"hmac-sha256"' if you require traitlets >=5.
  FutureWarning,
c:\miniconda3\envs\test\lib\site-packages\traitlets\traitlets.py:2349: FutureWarning: Supporting extra quotes around Bytes is deprecated in traitlets 5.0. Use '4b4da7a9-e832-49ef-985d-f4c5ee78e6eb' instead of 'b"4b4da7a9-e832-49ef-985d-f4c5ee78e6eb"'.
  FutureWarning,
Bad file descriptor (C:\projects\libzmq\src\epoll.cpp:100). 
View Jupyter log for further details.

解決方法

ライブラリのバージョンの問題っぽい。そのうち解決しそう。

pip uninstall pyzmq
pip install pyzmq==19.0.2

参考

https://stackoverflow.com/questions/70506366/failed-to-start-the-kernel-jupyter-in-vs-code

Discussion

コメントにはログインが必要です。